Quick search

Cython

Kivy 1.11.0.dev0 requires at least Cython version 0.23, and has been tested through 0.28.2. Later versions may work, but as they have not been tested there is no guarantee. The following versions of Cython have known issues and cannot be used with Kivy: 0.27, 0.27.2

Working versions

  • Kivy 1.11.0.dev0 -> Cython==0.28.2
  • Kivy 1.10.1 -> Cython==0.28.2
  • Kivy 1.10.0 -> Cython==0.25.2
  • Kivy 1.9.1 -> Cython==0.23.1
  • Kivy 1.9.0 -> Cython==0.21.2

To force a version of cython, use:

$ sudo pip install -U --force-reinstall Cython==<version>

where <version> is the appropriate version number.

Known issues

  • 0.27 -> Kivy Cython declaration bug in 1.10.0 causes failing compilation

Unsupported

  • 0.27 - 0.27.2 -> Kivy doesn’t compile on Python 3.4 with MinGWPy because of a used unexported symbol during the compilation. For more details see this issue.